Medium severity · published Nov 6, 2023
CVE-2023-5950
Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability
6.1
CVSS
0.5%
EPSS
No
On KEV
Description
Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability. This vulnerability allows attackers to inject JS into the error path, potentially leading to unauthorized execution of scripts within a user's web browser. This vulnerability is fixed in version 0.7.0-04 and a patch is available to download. Patches are also available for version 0.6.9 (0.6.9-1).
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 40% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VE
Velociraptor · Rapid7
before 0.6.9-1; 0.7.0; 0.7.0; 0.7.0-3 · source: NVD
Affected product
VE
Velociraptor
Rapid7
More from Velociraptor
9.9
CVE-2026-19072
Velociraptor Investigator reaches SuperUser via hunt EffectivePrincipal
9.9
CVE-2026-19583
Velociraptor Required Permissions bypass by using client monitoring queries
9.6
CVE-2026-18972
Velociraptor authenticated identity-spoofing vulnerability
9.1
CVE-2026-6290
Velociraptor Query() Plugin Misapplies Permissions To Orgs
8.9
CVE-2026-19200
Velociraptor Analyst overwrites live built-in artifacts through verify()