Medium severity · published Nov 2, 2023
CVE-2023-5917
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10
6.1
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 44% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PH
Phpbb · Phpbb
before 3.3.11 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-5917
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-5917
Patch
https://github.com/phpbb/phpbb/commit/ccf6e6c255d38692d72fcb613b113e6eaa240aac
Release Notes
https://github.com/phpbb/phpbb/releases/tag/release-3.3.11
Permissions Required
https://vuldb.com/?ctiid.244307
Third Party Advisory
https://vuldb.com/?id.244307
Product
https://www.phpbb.com/
Release Notes
https://www.phpbb.com/community/viewtopic.php?t=2646991
More from Phpbb
9.8
CVE-2026-48611
Improper authentication checks in the OAuth implementation allow account hijacking even when OAuth is not configured or enabled leading to unauthorized access in default…
8.8
CVE-2025-70810
Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker to execute arbitrary code via the login function and the authentication mechanism
8.8
CVE-2019-16993
In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel
8.8
CVE-2001-1471
prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute arbitrary PHP code via an invalid language value, which prevents the variables (1) $l_statsblock…
8.3
CVE-2026-87901
Improper sanitization in the registration module allows reflected Cross-Site Scripting
