Medium severity · published Nov 20, 2023
CVE-2023-48218
The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information
5.3
CVSS
0.6%
EPSS
No
On KEV
Description
The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 49% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PP
Protected Populate · Strapi
before 1.3.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-48218
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-48218
Patch
https://github.com/strapi-community/strapi-plugin-protected-populate/commit/05441066d64e09dd55937d9f089962e9ebe2fb39
Release Notes
https://github.com/strapi-community/strapi-plugin-protected-populate/releases/tag/v1.3.4
Vendor Advisory
https://github.com/strapi-community/strapi-plugin-protected-populate/security/advisories/GHSA-6h67-934r-82g7
