Medium severity · published Oct 10, 2023
CVE-2023-45648
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0…
5.3
CVSS
5.9%
EPSS
No
On KEV
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially
crafted, invalid trailer header could cause Tomcat to treat a single
request as multiple requests leading to the possibility of request
smuggling when behind a reverse proxy.
Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)5.9% · higher than 93% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TO
Tomcat · Apache
8.5.0 before 8.5.94; 9.0.1 before 9.0.81; 10.1.1 before 10.1.14; 9.0.0; 9.0.0; 9.0.0; +34 more · source: NVD
DL
Debian Linux · Debian
10.0; 11.0; 12.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-45648
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-45648
Vendor Advisory
https://lists.apache.org/thread/2pv8yz1pyp088tsxfb7ogltk9msk0jdp
Mailing List
http://www.openwall.com/lists/oss-security/2023/10/10/10
Mailing List
https://lists.debian.org/debian-lts-announce/2023/10/msg00020.html
security.netapp.com
https://security.netapp.com/advisory/ntap-20231103-0007/
Third Party Advisory
https://www.debian.org/security/2023/dsa-5521
Third Party Advisory
https://www.debian.org/security/2023/dsa-5522
More from Tomcat
9.8
CVE-2025-24813
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
9.8
CVE-2020-1938
Apache Tomcat Improper Privilege Management Vulnerability
9.8
CVE-2016-8735
Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if…
8.1
CVE-2017-12617
When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g
8.1
CVE-2017-12615
When running Apache Tomcat 7.0.0 to 7.0.79 on Windows with HTTP PUTs enabled (e.g
