Medium severity · published Sep 22, 2023
CVE-2023-43770
Roundcube Webmail Persistent Cross-Site Scripting (XSS) Vulnerability
In wildKEV
6.1
CVSS
63.7%
EPSS
Yes
On KEV
Description
Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)63.7% · higher than 99% of CVEs
Exploited in the wildYes
CISA KEVListed Feb 12, 2024
Federal remediation dueMar 4, 2024
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD, CISA
WE
Webmail · Roundcube
before 1.4.14; 1.5.0 before 1.5.4; 1.6.0 before 1.6.3 · source: NVD, CISA, KEV
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-43770
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-43770
CISA KEV catalogue
https://www.cisa.gov/known-exploited-vulnerabilities-catalog
github.com
https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b
roundcube.net
https://roundcube.net/news/2023/09/15/security-update-1.6.3-released
mailing-list
https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
