Medium severity · published Nov 16, 2023
CVE-2023-40314
Cross-site scripting in bootstrap.jsp
6.1
CVSS
0.4%
EPSS
No
On KEV
Description
Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Moshe Apelbaum for reporting this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 38% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
HO
Horizon · The OpenNMS Group
31.0.8 before 32.0.4 · source: vendor, NVD
ME
Meridian · Opennms
before 2023.1.9 · source: NVD
Affected product
HO
Horizon
The OpenNMS Group
More from Horizon
9.1
CVE-2026-111235
OpenNMS REST authorization bypass via non-canonical HTTP method
8.8
CVE-2023-40313
Disable BeanShell Interpreter Remote Server Mode
8.2
CVE-2026-89054
OpenNMS missing authorization on /api/v2 PATCH endpoints allows unauthenticated configuration changes
8.0
CVE-2023-40612
Authenticated XXE Injection Via The File Editor
8.0
CVE-2023-40315
ROLE_FILESYSTEM_EDITOR Can Be Used To Escalate To ROLE_ADMIN