Critical severity · published May 24, 2023
CVE-2023-33246
Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function
In wildKEV
9.8
CVSS
96.6%
EPSS
Yes
On KEV
Description
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)96.6% · higher than 100% of CVEs
Exploited in the wildYes
CISA KEVListed Sep 6, 2023
Federal remediation dueSep 27, 2023
Ransomware campaign useNot known
Affected products
Which versions
AR
Apache RocketMQ · Apache Software Foundation
through 5.1.0 · source: vendor
RO
Rocketmq · Apache
before 4.9.6; 5.0.0 before 5.1.1 · source: NVD, KEV