Medium severity · published Apr 24, 2023
CVE-2023-29530
Laminas Diactoros provides PSR HTTP Message implementations
6.5
CVSS
1%
EPSS
No
On KEV
Description
Laminas Diactoros provides PSR HTTP Message implementations. In versions 2.18.0 and prior, 2.19.0, 2.20.0, 2.21.0, 2.22.0, 2.23.0, 2.24.0, and 2.25.0, users who create HTTP requests or responses using laminas/laminas-diactoros, when providing a newline at the start or end of a header key or value, can cause an invalid message. This can lead to denial of service vectors or application errors. The problem has been patched in following versions 2.18.1, 2.19.1, 2.20.1, 2.21.1, 2.22.1, 2.23.1, 2.24.1, and 2.25.1. As a workaround, validate HTTP header keys and/or values, and if using user-supplied values, filter them to strip off leading or trailing newline characters before calling `withHeader()`.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 62% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FE
Fedora · Fedoraproject
38 · source: NVD
LA
Laminas-diactoros · Getlaminas
before 2.18.1; 2.19.0; 2.20.0; 2.21.0; 2.22.0; 2.23.0; +2 more · source: NVD
PS
Psr-7 · Guzzlephp
before 1.9.1; 2.0.0 before 2.4.5 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-29530
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-29530
Not Applicable
https://github.com/advisories/GHSA-wxmh-65f7-jcvw
Vendor Advisory
https://github.com/laminas/laminas-diactoros/security/advisories/GHSA-xv3h-4844-9h36
Mailing List
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BPW54QK7ISDALPLP2CKODU4ZIVRYS336/
More from Fedora
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2024-4577
Argument Injection in PHP-CGI
9.8
CVE-2021-44026
Roundcube Webmail SQL Injection Vulnerability
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
