High severity · published Apr 17, 2023
CVE-2023-29197
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP
7.5
CVSS
1.2%
EPSS
No
On KEV
Description
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 68% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FE
Fedora · Fedoraproject
37; 38 · source: NVD
PS
Psr-7 · Guzzlephp
before 1.9.1; 2.0.0 before 2.4.5 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-29197
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-29197
Not Applicable
https://cve.mitre.org/cgi-bin/cvename.cgi?name=2022-24775
Not Applicable
https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
Vendor Advisory
https://github.com/guzzle/psr7/security/advisories/GHSA-wxmh-65f7-jcvw
lists.debian.org
https://lists.debian.org/debian-lts-announce/2023/12/msg00028.html
Mailing List
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FJANWDXJZE5BGLN4MQ4FEHV5LJ6CMKQF/
Mailing List
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/O35UN4IK6VS2LXSRWUDFWY7NI73RKY2U/
More from Fedora
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2024-4577
Argument Injection in PHP-CGI
9.8
CVE-2021-44026
Roundcube Webmail SQL Injection Vulnerability
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
