High severity · published Mar 30, 2023
CVE-2023-28833
Nextcloud server is an open source home cloud implementation
8.8
CVSS
0.8%
EPSS
No
On KEV
Description
Nextcloud server is an open source home cloud implementation. In affected versions admins of a server were able to upload a logo or a favicon and to provided a file name which was not restricted and could overwrite files in the appdata directory. Administrators may have access to overwrite these files by other means but this method could be exploited by tricking an admin into uploading a maliciously named file. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should avoid ingesting logo files from untrusted sources.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NS
Nextcloud Server · Nextcloud
23.0.0 before 23.0.14; 24.0.0 before 24.0.10; 24.0.0 before 24.0.10; 25.0.0 before 25.0.4; 25.0.0 before 25.0.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-28833
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-28833
Vendor Advisory
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-ch7f-px7m-hg25
Issue Tracking
https://github.com/nextcloud/server/pull/36095
More from Nextcloud Server
9.8
CVE-2023-49792
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2023-48306
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2021-32802
Nextcloud server is an open source, self hosted personal cloud
9.8
CVE-2021-32726
Nextcloud Server is a Nextcloud package that handles data storage
9.8
CVE-2021-22915
Nextcloud server before 19.0.11, 20.0.10, 21.0.2 is vulnerable to brute force attacks due to lack of inclusion of IPv6 subnets in rate-limiting considerations
