Medium severity · published Feb 1, 2023
CVE-2023-23630
Cross-site (XSS) vulnerability with Express API in Eta
6.1
CVSS
0.6%
EPSS
No
On KEV
Description
Eta is an embedded JS templating engine that works inside Node, Deno, and the browser. XSS attack - anyone using the Express API is impacted. The problem has been resolved. Users should upgrade to version 2.0.0. As a workaround, don't pass user supplied things directly to `res.render`.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 49% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ET
eta · eta-dev
< 2.0.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-23630
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-23630
Patch
https://github.com/eta-dev/eta/commit/5651392462ee0ff19d77c8481081a99e5b9138dd
Release Notes
https://github.com/eta-dev/eta/releases/tag/v2.0.0
Third Party Advisory
https://github.com/eta-dev/eta/security/advisories/GHSA-xrh7-m5pp-39r6
