High severity · published Jan 26, 2023
CVE-2023-23614
Improper session handling of "Remember me for 7 days" functionality
8.8
CVSS
1%
EPSS
No
On KEV
Description
Pi-hole®'s Web interface (based off of AdminLTE) provides a central location to manage your Pi-hole. Versions 4.0 and above, prior to 5.18.3 are vulnerable to Insufficient Session Expiration. Improper use of admin WEBPASSWORD hash as "Remember me for 7 days" cookie value makes it possible for an attacker to "pass the hash" to login or reuse a theoretically expired "remember me" cookie. It also exposes the hash over the network and stores it unnecessarily in the browser. The cookie itself is set to expire after 7 days but its value will remain valid as long as the admin password doesn't change. If a cookie is leaked or compromised it could be used forever as long as the admin password is not changed. An attacker that obtained the password hash via an other attack vector (for example a path traversal vulnerability) could use it to login as the admin by setting the hash as the cookie value without the need to crack it to obtain the admin password (pass the hash). The hash is exposed over the network and in the browser where the cookie is transmitted and stored. This issue is patched in version 5.18.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 62% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AD
AdminLTE · pi-hole
<= 4.0, >= 5.18.3 · source: vendor
WI
Web Interface · Pi-hole
4.0 before 5.18.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2023-23614
CVE.org
https://www.cve.org/CVERecord?id=CVE-2023-23614
Exploit
https://github.com/pi-hole/AdminLTE/security/advisories/GHSA-33w4-xf7m-f82m
More from AdminLTE
7.2
CVE-2020-8816
Pi-Hole AdminLTE Remote Code Execution Vulnerability
8.8
CVE-2021-32706
(Authenticated) Remote Code Execution Possible in Web Interface 5.5
8.8
CVE-2021-29448
Stored DOM XSS in Pi-hole Admin Web Interface
5.4
CVE-2021-41175
Stored XSS in Client Groups Management (Authenticated)
5.3
CVE-2022-23513
Pi-Hole/AdminLTE vulnerable due to improper access control in queryads endpoint
