High severity · published Nov 15, 2022
CVE-2022-41916
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos
7.5
CVSS
1%
EPSS
No
On KEV
Description
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 62% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
HE
Heimdal · Heimdal Project
before 7.7.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41916
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41916
Third Party Advisory
https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
Mailing List
https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
security.gentoo.org
https://security.gentoo.org/glsa/202310-06
security.netapp.com
https://security.netapp.com/advisory/ntap-20230216-0008/
Third Party Advisory
https://www.debian.org/security/2022/dsa-5287
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
