Medium severity · published Dec 13, 2022
CVE-2022-41915
Netty project is an event-driven asynchronous network application framework
6.5
CVSS
1%
EPSS
No
On KEV
Description
Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 61% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
NE
Netty · Netty
4.1.83 before 4.1.86 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41915
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41915
Patch
https://github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
Exploit
https://github.com/netty/netty/issues/13084
Patch
https://github.com/netty/netty/pull/12760
Mitigation
https://github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
Mailing List
https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
Third Party Advisory
https://security.netapp.com/advisory/ntap-20230113-0004/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
