High severity · published Oct 25, 2022
CVE-2022-41704
Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input
7.5
CVSS
3.1%
EPSS
No
On KEV
Description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run untrusted Java code from an SVG. This issue affects Apache XML Graphics prior to 1.16. It is recommended to update to version 1.16.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.1% · higher than 88% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AX
Apache XML Graphics · Apache Software Foundation
Batik through 1.15 · source: vendor
BA
Batik · Apache
1.0 before 1.16 · source: NVD
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41704
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41704
Mailing List
http://www.openwall.com/lists/oss-security/2022/10/25/2
Vendor Advisory
https://lists.apache.org/thread/hplhx0o74jb7blj39fm4kw3otcnjd6xf
Mailing List
https://lists.debian.org/debian-lts-announce/2022/10/msg00038.html
security.gentoo.org
https://security.gentoo.org/glsa/202401-11
Third Party Advisory
https://www.debian.org/security/2022/dsa-5264
More from Apache XML Graphics
7.5
CVE-2022-42890
Apache Batik prior to 1.16 allows RCE via scripting
