High severity · published Dec 25, 2022
CVE-2022-41318
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6
8.6
CVSS
3.1%
EPSS
No
On KEV
Description
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)3.1% · higher than 88% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SQ
Squid · Squid-cache
2.5 before 5.7 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-41318
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-41318
Patch
http://www.squid-cache.org/Versions/v4/changesets/SQUID-2022_2.patch
Patch
http://www.squid-cache.org/Versions/v5/changesets/SQUID-2022_2.patch
Patch
https://github.com/squid-cache/squid/security/advisories/GHSA-394c-rr7q-6g78
Mailing List
https://www.openwall.com/lists/oss-security/2022/09/23/2
More from Squid
9.8
CVE-2025-54574
Squid is a caching proxy for the Web
9.8
CVE-2020-11945
An issue was discovered in Squid before 5.0.2
9.8
CVE-2019-12519
An issue was discovered in Squid through 4.7
9.8
CVE-2019-12524
An issue was discovered in Squid through 4.7
9.8
CVE-2019-12526
An issue was discovered in Squid before 4.9
