Medium severity · published Nov 25, 2022
CVE-2022-39346
Nextcloud server is an open source personal cloud server
6.5
CVSS
1.1%
EPSS
No
On KEV
Description
Nextcloud server is an open source personal cloud server. Affected versions of nextcloud server did not properly limit user display names which could allow a malicious users to overload the backing database and cause a denial of service. It is recommended that the Nextcloud Server is upgraded to 22.2.10, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 65% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FE
Fedora · Fedoraproject
35; 36; 37 · source: NVD
NE
Nextcloud Enterprise Server · Nextcloud
before 22.2.10; 23.0.0 before 23.0.7; 24.0.0 before 24.0.3 · source: NVD
NS
Nextcloud Server · Nextcloud
before 22.2.10; 23.0.0 before 23.0.7; 24.0.0 before 24.0.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-39346
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-39346
Third Party Advisory
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-6w9f-jgjx-4vj6
Patch
https://github.com/nextcloud/server/pull/33052
Permissions Required
https://hackerone.com/reports/1588562
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/42TARDPRPBTI5TJRBYRVVQGTL6KWRCV5/
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R32L3P53AQKQQC652LA5U3AWFTZKPDK3/
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TRAER4DCCHHSUDFHQ6LTIH4JEJFF73IU/
More from Fedora
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2024-4577
Argument Injection in PHP-CGI
9.8
CVE-2021-44026
Roundcube Webmail SQL Injection Vulnerability
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
