Medium severity · published Aug 3, 2022
CVE-2022-31175
Cross-site scripting caused by the editor instance destroying process in ckeditor5
4.7
CVSS
0.9%
EPSS
No
On KEV
Description
CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 59% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CK
ckeditor5 · ckeditor
< 35.0.1 · source: vendor
CK
Ckeditor5-html-embed · Ckeditor
before 35.0.1 · source: NVD
CK
Ckeditor5-html-support · Ckeditor
before 35.0.1 · source: NVD
CK
Ckeditor5-markdown-gfm · Ckeditor
before 35.0.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-31175
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-31175
Vendor Advisory
https://ckeditor.com/docs/ckeditor5/latest/features/general-html-support.html
Vendor Advisory
https://ckeditor.com/docs/ckeditor5/latest/features/html-embed.html
Vendor Advisory
https://ckeditor.com/docs/ckeditor5/latest/features/markdown.html
Third Party Advisory
https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-42wq-rch8-6f6j
More from ckeditor5
8.1
CVE-2026-116688
CKEditor: Cross-site scripting (XSS) in the engine package
6.5
CVE-2021-21254
CKEditor 5 is an open source rich text editor framework with a modular architecture
6.1
CVE-2026-28343
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture
6.1
CVE-2024-45613
CKEditor 5 is a JavaScript rich-text editor
5.4
CVE-2025-61261
A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular v18.0.0 allows attackers to execute arbitrary code in the context of a user's browser via…
