High severity · published Jul 15, 2022
CVE-2022-31158
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP
7.5
CVSS
0.9%
EPSS
No
On KEV
Description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 58% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
L1
Lti 1.3 Tool Library · Packback
before 5.0.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-31158
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-31158
Third Party Advisory
https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h
More from Lti 1.3 Tool Library
7.5
CVE-2022-31157
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP
