Medium severity · published Jun 9, 2022
CVE-2022-31030
containerd is an open source container runtime
5.5
CVSS
0.4%
EPSS
No
On KEV
Description
containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 33% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
Containerd · Linuxfoundation
before 1.5.13; 1.6.0 before 1.6.6 · source: NVD
DL
Debian Linux · Debian
11.0 · source: NVD
FE
Fedora · Fedoraproject
35; 36 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-31030
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-31030
Mailing List
http://www.openwall.com/lists/oss-security/2022/06/07/1
Product
https://github.com/containerd/containerd/commit/c1bcabb4541930f643aa36a2b38655e131346382
Third Party Advisory
https://github.com/containerd/containerd/security/advisories/GHSA-5ffw-gxpp-mxpf
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/REOZCUAPCA7NFDWYBDYX6EYXWLHABKBO/
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSIGDBHAB3I75JBJNGWEPBTJPS2FOVHD/
security.gentoo.org
https://security.gentoo.org/glsa/202401-31
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
