High severity · published Oct 6, 2022
CVE-2022-31008
Predictable credential obfuscation seed value used in rabbitmq-server
7.5
CVSS
0.4%
EPSS
No
On KEV
Description
RabbitMQ is a multi-protocol messaging and streaming broker. In affected versions the shovel and federation plugins perform URI obfuscation in their worker (link) state. The encryption key used to encrypt the URI was seeded with a predictable secret. This means that in case of certain exceptions related to Shovel and Federation plugins, reasonably easily deobfuscatable data could appear in the node log. Patched versions correctly use a cluster-wide secret for that purpose. This issue has been addressed and Patched versions: `3.10.2`, `3.9.18`, `3.8.32` are available. Users unable to upgrade should disable the Shovel and Federation plugins.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 34% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
RA
rabbitmq-server · rabbitmq
< 3.8.32; >= 3.9.0, < 3.9.18; >= 3.10.0, < 3.10.2 · source: vendor
RA
Rabbitmq · Vmware
before 3.8.32 · source: NVD
RS
Rabbitmq Server · Broadcom
3.9.0 before 3.9.18; 3.10.0 before 3.10.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-31008
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-31008
Patch
https://github.com/rabbitmq/rabbitmq-server/pull/4841
Third Party Advisory
https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-v9gv-xp36-jgj8
More from rabbitmq-server
10.0
CVE-2026-57216
RabbitMQ: AMQP 1.0, AMQP 0-9-1, Stream Protocol loopback enforcement can lead to remote guest sessions due to listener-address loopback checks
10.0
CVE-2026-57211
RabbitMQ: UNC SSRF affecting the management UI on Windows
9.3
CVE-2026-67237
RabbitMQ: Reflected XSS via the OAuth bootstrap JS endpoint
9.1
CVE-2026-67231
RabbitMQ: Trust-store whitelist by Issuer+Serial only
8.8
CVE-2026-66070
RabbitMQ: CORS * reflects Origin with Allow-Credentials
