High severity · published Mar 30, 2022
CVE-2022-25598
Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or…
7.5
CVSS
2%
EPSS
No
On KEV
Description
Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.0% · higher than 80% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DO
Dolphinscheduler · Apache
before 2.0.5 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-25598
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-25598
Mailing List
https://lists.apache.org/thread/hwnw7xr969sg5nv84wz75nfr2c76fl93
More from Dolphinscheduler
9.8
CVE-2026-32966
Apache DolphinScheduler: DataSource API Missing Authorization Check Leads to Arbitrary Data Source Metadata Disclosure
9.8
CVE-2024-43166
Incorrect Default Permissions vulnerability in Apache DolphinScheduler
9.8
CVE-2024-43202
Exposure of Remote Code Execution in Apache Dolphinscheduler
9.8
CVE-2023-49109
Exposure of Remote Code Execution in Apache Dolphinscheduler
9.8
CVE-2022-45875
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability
