High severity · published Apr 11, 2022
CVE-2022-24836
Nokogiri is an open source XML and HTML library for Ruby
7.5
CVSS
3.5%
EPSS
No
On KEV
Description
Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.5% · higher than 89% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
MA
macOS · Apple
13.0 before 13.1 · source: NVD
DL
Debian Linux · Debian
9.0; 10.0 · source: NVD
FE
Fedora · Fedoraproject
34; 35; 36 · source: NVD
NO
Nokogiri · Nokogiri
before 1.13.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-24836
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-24836
Mailing List
http://seclists.org/fulldisclosure/2022/Dec/23
Patch
https://github.com/sparklemotion/nokogiri/commit/e444525ef1634b675cd1cf52d39f4320ef0aecfd
Third Party Advisory
https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-crjr-9rc5-ghw8
Mailing List
https://lists.debian.org/debian-lts-announce/2022/05/msg00013.html
Mailing List
https://lists.debian.org/debian-lts-announce/2022/10/msg00018.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6DHCOWMA5PQTIQIMDENA7R2Y5BDYAIYM/
More from macOS
10.0
CVE-2025-43300
Apple iOS, iPadOS, and macOS Out-of-Bounds Write Vulnerability
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2025-24085
Apple Multiple Products Use-After-Free Vulnerability
9.8
CVE-2026-65400
Apple macOS Improper Authentication Vulnerability
9.8
CVE-2025-31200
Apple Multiple Products Memory Corruption Vulnerability
