High severity · published Apr 4, 2022
CVE-2022-24785
Moment.js is a JavaScript date library for parsing, validating, manipulating, and formatting dates
7.5
CVSS
13.8%
EPSS
No
On KEV
Description
Moment.js is a JavaScript date library for parsing, validating, manipulating, and formatting dates. A path traversal vulnerability impacts npm (server) users of Moment.js between versions 1.0.1 and 2.29.1, especially if a user-provided locale string is directly used to switch moment locale. This problem is patched in 2.29.2, and the patch can be applied to all affected versions. As a workaround, sanitize the user-provided locale name before passing it to Moment.js.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)13.8% · higher than 97% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AI
Active IQ · Netapp
All versions, or not specified · source: NVD
DL
Debian Linux · Debian
10.0 · source: NVD
FE
Fedora · Fedoraproject
35; 36 · source: NVD
MO
Moment · Momentjs
1.0.1 before 2.29.2; 1.0.1 before 2.29.2 · source: NVD
TE
Tenable.sc · Tenable
before 5.21.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-24785
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-24785
Patch
https://github.com/moment/moment/commit/4211bfc8f15746be4019bba557e29a7ba83d54c5
Vendor Advisory
https://github.com/moment/moment/security/advisories/GHSA-8hfj-j24r-96c4
Mailing List
https://lists.debian.org/debian-lts-announce/2023/01/msg00035.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6QIO6YNLTK2T7SPKDS4JEL45FANLNC2Q/
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ORJX2LF6KMPIHP6B2P6KZIVKMLE3LVJ5/
Third Party Advisory
https://security.netapp.com/advisory/ntap-20220513-0006/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
