High severity · published Mar 21, 2022
CVE-2022-24775
guzzlehttp/psr7 is a PSR-7 HTTP message library
7.5
CVSS
2.5%
EPSS
No
On KEV
Description
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.5% · higher than 84% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DR
Drupal · Drupal
8.0.0 before 9.2.16; 9.3.0 before 9.3.9 · source: NVD
PS
Psr-7 · Guzzlephp
before 1.8.4; 2.0.0 before 2.1.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-24775
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-24775
Patch
https://github.com/guzzle/psr7/pull/485/commits/e55afaa3fc138c89adf3b55a8ba20dc60d17f1f1
Patch
https://github.com/guzzle/psr7/pull/486/commits/9a96d9db668b485361ed9de7b5bf1e54895df1dc
Third Party Advisory
https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
Patch
https://www.drupal.org/sa-core-2022-006
More from Drupal
9.8
CVE-2026-9082
Drupal core - Highly critical - SQL injection - SA-CORE-2026-004
9.8
CVE-2018-7602
Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004
9.8
CVE-2018-7600
Drupal Core Remote Code Execution Vulnerability
8.8
CVE-2020-13671
Drupal core Un-restricted Upload of File
8.1
CVE-2019-6340
Drupal core - Highly critical - Remote Code Execution
