Medium severity · published Feb 25, 2022
CVE-2022-24710
Weblate is a copyleft software web-based continuous localization system
5.4
CVSS
0.8%
EPSS
No
On KEV
Description
Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.8% · higher than 55% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WE
Weblate · Weblate
before 4.11 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-24710
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-24710
Patch
https://github.com/WeblateOrg/weblate/commit/22d577b1f1e88665a88b4569380148030e0f8389
Patch
https://github.com/WeblateOrg/weblate/commit/9e19a8414337692cc90da2a91c9af5420f2952f1
Patch
https://github.com/WeblateOrg/weblate/commit/f6753a1a1c63fade6ad418fbda827c6750ab0bda
Patch
https://github.com/WeblateOrg/weblate/security/advisories/GHSA-6jp6-9rf9-gc66
More from Weblate
9.8
CVE-2025-64725
Weblate has improper validation upon invitation acceptance
9.1
CVE-2026-24126
Weblate has an argument injection in management console
9.1
CVE-2025-68398
Weblate has git config file overwrite vulnerability that leads to remote code execution
8.8
CVE-2026-34393
Weblate: Privilege escalation in the user API endpoint
8.8
CVE-2022-23915
The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories
