High severity · published Mar 3, 2022
CVE-2022-23648
containerd is a container runtime available as a daemon for Linux and Windows
7.5
CVSS
27.4%
EPSS
No
On KEV
Description
containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)27.4% · higher than 98% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CO
Containerd · Linuxfoundation
before 1.4.13; 1.5.0 before 1.5.10; 1.6.0 before 1.6.1 · source: NVD
DL
Debian Linux · Debian
11.0 · source: NVD
FE
Fedora · Fedoraproject
34; 35; 36 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-23648
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-23648
Exploit
http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
Patch
https://github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
Patch
https://github.com/containerd/containerd/releases/tag/v1.4.13
Patch
https://github.com/containerd/containerd/releases/tag/v1.5.10
Patch
https://github.com/containerd/containerd/releases/tag/v1.6.1
Third Party Advisory
https://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
