Medium severity · published Feb 11, 2022
CVE-2022-23634
Puma is a Ruby/Rack web server built for parallelism
5.9
CVSS
2.1%
EPSS
No
On KEV
Description
Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.1% · higher than 82% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0; 10.0; 11.0 · source: NVD
FE
Fedora · Fedoraproject
35; 36; 37 · source: NVD
PU
Puma · Puma
before 4.3.11; 5.0.0 before 5.6.2 · source: NVD
RA
Rails · Rubyonrails
5.0.0 before 5.2.6.2; 6.0.0 before 6.0.4.6; 6.1.0 before 6.1.4.6; 7.0.0 before 7.0.2.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-23634
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-23634
Third Party Advisory
https://github.com/advisories/GHSA-rmj8-8hhh-gv5h
Mitigation
https://github.com/advisories/GHSA-wh98-p28r-vrc9
Patch
https://github.com/puma/puma/commit/b70f451fe8abc0cff192c065d549778452e155bb
Patch
https://github.com/puma/puma/security/advisories/GHSA-rmj8-8hhh-gv5h
Mailing List
https://groups.google.com/g/ruby-security-ann/c/FkTM-_7zSNA/m/K2RiMJBlBAAJ?utm_medium=email&utm_source=footer&pli=1
Mailing List
https://lists.debian.org/debian-lts-announce/2022/05/msg00034.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
