Medium severity · published Feb 11, 2022
CVE-2022-23633
Action Pack is a framework for handling and responding to web requests
5.9
CVSS
2.2%
EPSS
No
On KEV
Description
Action Pack is a framework for handling and responding to web requests. Under certain circumstances response bodies will not be closed. In the event a response is *not* notified of a `close`, `ActionDispatch::Executor` will not know to reset thread local state for the next request. This can lead to data being leaked to subsequent requests.This has been fixed in Rails 7.0.2.1, 6.1.4.5, 6.0.4.5, and 5.2.6.1. Upgrading is highly recommended, but to work around this problem a middleware described in GHSA-wh98-p28r-vrc9 can be used.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.2% · higher than 83% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0; 11.0 · source: NVD
RA
Rails · Rubyonrails
5.0.0 before 5.2.6.2; 6.0.0 before 6.0.4.6; 6.1.0 before 6.1.4.6; 7.0.0 before 7.0.2.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-23633
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-23633
Mailing List
http://www.openwall.com/lists/oss-security/2022/02/11/5
Patch
https://github.com/rails/rails/commit/f9a2ad03943d5c2ba54e1d45f155442b519c75da
Mitigation
https://github.com/rails/rails/security/advisories/GHSA-wh98-p28r-vrc9
Mailing List
https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
security.netapp.com
https://security.netapp.com/advisory/ntap-20240119-0013/
Third Party Advisory
https://www.debian.org/security/2023/dsa-5372
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
