Medium severity · published Dec 14, 2022
CVE-2022-23519
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications
6.1
CVSS
1.1%
EPSS
No
On KEV
Description
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Prior to version 1.4.4, a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags in either of the following ways: allow both "math" and "style" elements, or allow both "svg" and "style" elements. Code is only impacted if allowed tags are being overridden. . This issue is fixed in version 1.4.4. All users overriding the allowed tags to include "math" or "svg" and "style" should either upgrade or use the following workaround immediately: Remove "style" from the overridden allowed tags, or remove "math" and "svg" from the overridden allowed tags.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 64% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
RH
Rails Html Sanitizers · Rubyonrails
before 1.4.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-23519
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-23519
Exploit
https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-9h9g-93gc-623h
Exploit
https://hackerone.com/reports/1656627
Mailing List
https://lists.debian.org/debian-lts-announce/2023/09/msg00012.html
lists.debian.org
https://lists.debian.org/debian-lts-announce/2024/09/msg00045.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
