Medium severity · published Dec 14, 2022
CVE-2022-23515
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri
6.1
CVSS
0.9%
EPSS
No
On KEV
Description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.9% · higher than 58% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
LO
Loofah · Loofah Project
2.1.0 before 2.19.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2022-23515
CVE.org
https://www.cve.org/CVERecord?id=CVE-2022-23515
Issue Tracking
https://github.com/flavorjones/loofah/issues/101
Third Party Advisory
https://github.com/flavorjones/loofah/security/advisories/GHSA-228g-948r-83gx
Permissions Required
https://hackerone.com/reports/1694173
Mailing List
https://lists.debian.org/debian-lts-announce/2023/09/msg00011.html
lists.debian.org
https://lists.debian.org/debian-lts-announce/2024/09/msg00044.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
