High severity · published Nov 24, 2021
CVE-2021-43778
Barcode is a GLPI plugin for printing barcodes and QR codes
7.5
CVSS
52.7%
EPSS
No
On KEV
Description
Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)52.7% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BA
Barcode · Glpi-project
2.0 before 2.6.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-43778
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-43778
Exploit
https://github.com/hansmach1ne/MyExploits/tree/main/Path%20Traversal%20in%20GLPI%20Barcode%20plugin
Patch
https://github.com/pluginsGLPI/barcode/commit/428c3d9adfb446e8492b1c2b7affb3d34072ff46
Release Notes
https://github.com/pluginsGLPI/barcode/releases/tag/2.6.1
Patch
https://github.com/pluginsGLPI/barcode/security/advisories/GHSA-2pjh-h828-wcw9
github.com
https://github.com/hansmach1ne/CVE-portfolio/tree/main/CVE-2021-43778
