Medium severity · published Nov 17, 2021
CVE-2021-41164
CKEditor4 is an open source WYSIWYG HTML editor
5.4
CVSS
1.3%
EPSS
No
On KEV
Description
CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.3% · higher than 71% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DR
Drupal · Drupal
8.9.0 before 8.9.20; 9.1.0 before 9.1.14; 9.2.0 before 9.2.9 · source: NVD
AE
Application Express · Oracle
before 22.1 · source: NVD
BA
Banking Apis · Oracle
18.1 through 18.3; 19.1; 19.2; 20.1; 21.1 · source: NVD
BD
Banking Digital Experience · Oracle
18.1 through 18.3; 19.1; 19.2; 20.1; 21.1 · source: NVD
CK
Ckeditor · Ckeditor
4.0 before 4.17.0 · source: NVD
CG
FE
Fedora · Fedoraproject
36; 37 · source: NVD
WP
Webcenter Portal · Oracle
12.2.1.3.0; 12.2.1.4.0 · source: NVD