High severity · published Sep 3, 2021
CVE-2021-39192
Privilege escalation: all users can access Admin-level API keys
7.2
CVSS
1%
EPSS
No
On KEV
Description
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.0% · higher than 63% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
GH
Ghost · TryGhost
>= 4.0.0, < 4.10.0 · source: vendor, NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-39192
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-39192
Release Notes
https://github.com/TryGhost/Ghost/releases/tag/v4.10.0
Third Party Advisory
https://github.com/TryGhost/Ghost/security/advisories/GHSA-j5c2-hm46-wp5c
More from Ghost
9.8
CVE-2026-29053
Ghost Vulnerable to Remote Code Execution via Malicious Themes
9.6
CVE-2026-53943
Ghost: Cache-poisoning XSS in Ghost frontend via x-ghost-preview header
8.8
CVE-2026-105642
Ghost: Remote Code Execution via Bookmark Card Images
8.8
CVE-2026-103268
Ghost 1.0.0 before 6.62.0 Suspension Bypass via Password Reset
8.8
CVE-2026-29784
Ghost: Incomplete CSRF protections around OTC use
