Medium severity · published Sep 22, 2021
CVE-2021-38153
Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more…
5.9
CVSS
6.2%
EPSS
No
On KEV
Description
Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)6.2% · higher than 93% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CB
Communications Brm - Elastic Charging Engine · Oracle
before 12.0.0.4.6; 12.0.0.5.0 · source: NVD
FS
Financial Services Analytical Applications Infrastructure · Oracle
8.0.6.0 through 8.0.9.0; 8.1.0.0.0 through 8.1.20 · source: NVD
FS
Financial Services Behavior Detection Platform · Oracle
8.0.6.0.0 through 8.0.8.0; 8.1.1.0; 8.1.1.1; 8.1.2.0 · source: NVD
FS
Financial Services Enterprise Case Management · Oracle
8.0.7.1; 8.0.7.2; 8.0.8.0; 8.0.8.1; 8.1.1.0; 8.1.1.1 · source: NVD
KA
Kafka · Apache
2.0.0 before 2.6.3; 2.7.0 before 2.7.2; 2.8.0 · source: NVD
PU
Primavera Unifier · Oracle
18.8; 19.12; 20.12; 21.12 · source: NVD
QU
Quarkus · Quarkus
before 2.2.4 · source: NVD
Affected product
KA
Kafka
Apache
More from Kafka
9.1
CVE-2026-33557
Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication
8.8
CVE-2025-27818
A possible security vulnerability has been identified in Apache Kafka
8.8
CVE-2018-17196
In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation
8.7
CVE-2026-35554
Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition
7.5
CVE-2025-27819
In CVE-2023-25194, we announced the RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration in Kafka Connect API