Medium severity · published Aug 12, 2021
CVE-2021-37704
PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache)
4.3
CVSS
5.9%
EPSS
No
On KEV
Description
PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). In versions before 6.1.5, 7.1.2, and 8.0.7 the `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will **NOT** be patched. As a workaround, protect the `/vendor` directory from public access.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)5.9% · higher than 93% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PH
Phpfastcache · Phpfastcache
before 6.1.5; 7.0.0 before 7.1.2; 8.0.0 before 8.0.7 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-37704
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-37704
Release Notes
https://github.com/PHPSocialNetwork/phpfastcache/blob/master/CHANGELOG.md#807
Patch
https://github.com/PHPSocialNetwork/phpfastcache/commit/41a77d0d8f126dbd6fbedcd9e6a82e86cdaafa51
Patch
https://github.com/PHPSocialNetwork/phpfastcache/pull/813
Third Party Advisory
https://github.com/PHPSocialNetwork/phpfastcache/pull/814
Third Party Advisory
https://github.com/PHPSocialNetwork/phpfastcache/pull/815
Third Party Advisory
https://github.com/PHPSocialNetwork/phpfastcache/security/advisories/GHSA-cvh5-p6r6-g2qc
More from Phpfastcache
9.8
CVE-2019-16774
In phpfastcache before 5.1.3, there is a possible object injection vulnerability in cookie driver
