Medium severity · published Jul 22, 2021
CVE-2021-3619
Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype…
4.8
CVSS
0.6%
EPSS
No
On KEV
Description
Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 47% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
VE
Velociraptor · Rapid7
before 0.6.0 · source: NVD
Affected product
VE
Velociraptor
Rapid7
More from Velociraptor
9.9
CVE-2026-19072
Velociraptor Investigator reaches SuperUser via hunt EffectivePrincipal
9.9
CVE-2026-19583
Velociraptor Required Permissions bypass by using client monitoring queries
9.6
CVE-2026-18972
Velociraptor authenticated identity-spoofing vulnerability
9.1
CVE-2026-6290
Velociraptor Query() Plugin Misapplies Permissions To Orgs
8.9
CVE-2026-19200
Velociraptor Analyst overwrites live built-in artifacts through verify()