High severity · published Mar 25, 2021
CVE-2021-3450
CA certificate check bypass with X509_V_FLAG_X509_STRICT
7.4
CVSS
18.3%
EPSS
No
On KEV
Description
The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)18.3% · higher than 97% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WS
WebLogic Server · Oracle
12.2.1.4.0; 14.1.1.0.0 · source: NVD
OP
OpenSSL · OpenSSL
Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j) · source: vendor, NVD
CC
Capture Client · Sonicwall
before 3.6.24 · source: NVD
CV
Cloud Volumes Ontap Mediator · Netapp
All versions, or not specified · source: NVD
CG
Commerce Guided Search · Oracle
11.3.2 · source: NVD
ES
Email Security · Sonicwall
before 10.0.11 · source: NVD
EM
Enterprise Manager For Storage Management · Oracle
13.4.0.0 · source: NVD
FE
Fedora · Fedoraproject
34 · source: NVD
FR
Freebsd · Freebsd
12.2; 12.2; 12.2 · source: NVD
GR
Graalvm · Oracle
19.3.5; 20.3.1.2; 21.0.0.2 · source: NVD
JE
JD Edwards Enterpriseone Tools · Oracle
before 9.2.6.0 · source: NVD
JE
JD Edwards World Security · Oracle
a9.4 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-3450
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-3450
Mailing List
http://www.openwall.com/lists/oss-security/2021/03/27/1
Mailing List
http://www.openwall.com/lists/oss-security/2021/03/27/2
Mailing List
http://www.openwall.com/lists/oss-security/2021/03/28/3
Mailing List
http://www.openwall.com/lists/oss-security/2021/03/28/4
Third Party Advisory
https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
git.openssl.org
https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=2a40b7bc7b94dd7de897a74571e7024f0cf0d63b
More from WebLogic Server
9.8
CVE-2022-22965
Spring Framework JDK 9+ Remote Code Execution Vulnerability
9.8
CVE-2020-14750
Oracle WebLogic Server Remote Code Execution Vulnerability
9.8
CVE-2020-14882
Oracle WebLogic Server Remote Code Execution Vulnerability
9.8
CVE-2020-14644
Oracle WebLogic Server Remote Code Execution Vulnerability
9.8
CVE-2020-2883
Oracle WebLogic Server Unspecified Vulnerability
