Medium severity · published Jul 12, 2021
CVE-2021-32733
Nextcloud Text is a collaborative document editing application that uses Markdown
6.1
CVSS
1.1%
EPSS
No
On KEV
Description
Nextcloud Text is a collaborative document editing application that uses Markdown. A cross-site scripting vulnerability is present in versions prior to 19.0.13, 20.0.11, and 21.0.3. The Nextcloud Text application shipped with Nextcloud server used a `text/html` Content-Type when serving files to users. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. The issue was fixed in versions 19.0.13, 20.0.11, and 21.0.3. As a workaround, use a browser that has support for Content-Security-Policy.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 66% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
NS
Nextcloud Server · Nextcloud
before 19.0.13; 20.0.0 before 20.0.11; 21.0.0 before 21.0.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-32733
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-32733
Third Party Advisory
https://github.com/nextcloud/security-advisories/security/advisories/GHSA-x4w3-jhcr-57pq
Patch
https://github.com/nextcloud/text/pull/1689
Permissions Required
https://hackerone.com/reports/1241460
More from Nextcloud Server
9.8
CVE-2023-49792
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2023-48306
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform
9.8
CVE-2021-32802
Nextcloud server is an open source, self hosted personal cloud
9.8
CVE-2021-32726
Nextcloud Server is a Nextcloud package that handles data storage
9.8
CVE-2021-22915
Nextcloud server before 19.0.11, 20.0.10, 21.0.2 is vulnerable to brute force attacks due to lack of inclusion of IPv6 subnets in rate-limiting considerations
