Medium severity · published Apr 15, 2021
CVE-2021-29447
Wordpress is an open source CMS
6.5
CVSS
85.7%
EPSS
No
On KEV
Description
Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)85.7% · higher than 100% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WO
WordPress · WordPress
5.6.0 before 5.7.1 · source: NVD
DL
Debian Linux · Debian
9.0; 10.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-29447
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-29447
Third Party Advisory
http://packetstormsecurity.com/files/163148/XML-External-Entity-Via-MP3-File-Upload-On-WordPress.html
Exploit
http://packetstormsecurity.com/files/164198/WordPress-5.7-Media-Library-XML-Injection.html
Exploit
https://blog.sonarsource.com/wordpress-xxe-security-vulnerability/
Third Party Advisory
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-rv47-pc52-qrhh
Mailing List
https://lists.debian.org/debian-lts-announce/2021/04/msg00017.html
Release Notes
https://wordpress.org/news/category/security/
More from WordPress
9.8
CVE-2026-63030
WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution
9.8
CVE-2020-25213
WordPress File Manager Plugin Remote Code Execution Vulnerability
9.8
CVE-2016-10033
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute…
8.1
CVE-2026-87902
WordPress Core Remote File Inclusion Vulnerability
7.5
CVE-2020-11738
WordPress Snap Creek Duplicator Plugin File Download Vulnerability
