High severity · published Feb 16, 2021
CVE-2021-23840
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable…
7.5
CVSS
50.7%
EPSS
No
On KEV
Description
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)50.7% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BI
Business Intelligence · Oracle
5.5.0.0.0; 5.9.0.0.0; 12.2.1.3.0; 12.2.1.4.0 · source: NVD
CC
Communications Cloud Native Core Policy · Oracle
1.15.0 · source: NVD
DL
Debian Linux · Debian
10.0 · source: NVD
EM
Enterprise Manager For Storage Management · Oracle
13.4.0.0 · source: NVD
EM
Enterprise Manager Ops Center · Oracle
12.4.0.0 · source: NVD
EO
Epolicy Orchestrator · Mcafee
before 5.10.0; 5.10.0; 5.10.0; 5.10.0; 5.10.0; 5.10.0; +6 more · source: NVD
GR
Graalvm · Oracle
19.3.5; 20.3.1.2; 21.0.0.2 · source: NVD
JE
JD Edwards Enterpriseone Tools · Oracle
before 9.2.6.0 · source: NVD
JE
JD Edwards World Security · Oracle
a9.4 · source: NVD
LC
Log Correlation Engine · Tenable
before 6.0.8 · source: NVD
MF
M10-1 Firmware · Fujitsu
before xcp2410; before xcp3110 · source: NVD
MF
M10-4 Firmware · Fujitsu
before xcp2410; before xcp3110 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-23840
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-23840
Third Party Advisory
https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
git.openssl.org
https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=6a51b9e1d0cf0bf8515f7201b68fb0a3482b3dc1
git.openssl.org
https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=9b1129239f3ebb1d1c98ce9ed41d5c9476c47cb2
Third Party Advisory
https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846
Third Party Advisory
https://kc.mcafee.com/corporate/index?page=content&id=SB10366
lists.apache.org
https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-24061
GNU InetUtils Argument Injection Vulnerability
