Low severity · published Feb 16, 2021
CVE-2021-23839
OpenSSL 1.0.2 supports SSLv2
3.7
CVSS
3%
EPSS
No
On KEV
Description
OpenSSL 1.0.2 supports SSLv2. If a client attempts to negotiate SSLv2 with a server that is configured to support both SSLv2 and more recent SSL and TLS versions then a check is made for a version rollback attack when unpadding an RSA signature. Clients that support SSL or TLS versions greater than SSLv2 are supposed to use a special form of padding. A server that supports greater than SSLv2 is supposed to reject connection attempts from a client where this special form of padding is present, because this indicates that a version rollback has occurred (i.e. both client and server support greater than SSLv2, and yet this is the version that is being requested). The implementation of this padding check inverted the logic so that the connection attempt is accepted if the padding is present, and rejected if it is absent. This means that such as server will accept a connection if a version rollback attack has occurred. Further the server will erroneously reject a connection if a normal SSLv2 connection attempt is made. Only OpenSSL 1.0.2 servers from version 1.0.2s to 1.0.2x are affected by this issue. In order to be vulnerable a 1.0.2 server must: 1) have configured SSLv2 support at compile time (this is off by default), 2) have configured SSLv2 support at runtime (this is off by default), 3) have configured SSLv2 ciphersuites (these are not in the default ciphersuite list) OpenSSL 1.1.1 does not have SSLv2 support and therefore is not vulnerable to this issue. The underlying error is in the implementation of the RSA_padding_check_SSLv23() function. This also affects the RSA_SSLV23_PADDING padding mode used by various other functions. Although 1.1.1 does not support SSLv2 the RSA_padding_check_SSLv23() function still exists, as does the RSA_SSLV23_PADDING padding mode. Applications that directly call that function or use that padding mode will encounter this issue. However since there is no support for the SSLv2 protocol in 1.1.1 this is considered a bug and not a security issue in that version. OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.0.2y (Affected 1.0.2s-1.0.2x).
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.0% · higher than 87% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BI
Business Intelligence · Oracle
5.5.0.0.0; 5.9.0.0.0; 12.2.1.3.0; 12.2.1.4.0 · source: NVD
EM
Enterprise Manager For Storage Management · Oracle
13.4.0.0 · source: NVD
EM
Enterprise Manager Ops Center · Oracle
12.4.0.0 · source: NVD
GR
Graalvm · Oracle
19.3.5; 20.3.1.2; 21.0.0.2 · source: NVD
JE
JD Edwards World Security · Oracle
a9.4 · source: NVD
OP
Openssl · Openssl
1.0.2s through 1.0.2x · source: NVD
SI
Sinec Ins · Siemens
before 1.0; 1.0; 1.0 · source: NVD
ZS
Zfs Storage Appliance Kit · Oracle
8.8 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-23839
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-23839
Patch
https://cert-portal.siemens.com/productcert/pdf/ssa-637483.pdf
git.openssl.org
https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=30919ab80a478f2d81f2e9acdcca3fa4740cd547
Third Party Advisory
https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846
Third Party Advisory
https://security.netapp.com/advisory/ntap-20210219-0009/
security.netapp.com
https://security.netapp.com/advisory/ntap-20240621-0006/
Vendor Advisory
https://www.openssl.org/news/secadv/20210216.txt
More from Openssl
7.5
CVE-2014-0160
OpenSSL Information Disclosure Vulnerability
9.8
CVE-2026-63073
Untrusted Sender DN Used as Format String in CMP Response Validation
9.8
CVE-2026-31789
Heap Buffer Overflow in Hexadecimal Conversion
9.8
CVE-2022-2274
RSA implementation bug in AVX512IFMA instructions
9.8
CVE-2021-3711
SM2 Decryption Buffer Overflow
