Medium severity · published Feb 16, 2021
CVE-2021-21317
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser
5.3
CVSS
2.5%
EPSS
No
On KEV
Description
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.5% · higher than 85% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
UA
Uap-core · Uap-core Project
before 0.11.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-21317
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-21317
Patch
https://github.com/ua-parser/uap-core/commit/dc9925d458214cfe87b93e35346980612f6ae96c
Third Party Advisory
https://github.com/ua-parser/uap-core/security/advisories/GHSA-p4pj-mg4r-x6v4
Product
https://www.npmjs.com/package/uap-core
More from Uap-core
7.5
CVE-2020-5243
uap-core before 0.7.3 is vulnerable to a denial of service attack when processing crafted User-Agent strings
