High severity · published Feb 11, 2021
CVE-2021-21299
hyper is an open-source HTTP library for Rust (crates.io)
8.1
CVSS
4.7%
EPSS
No
On KEV
Description
hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)4.7% · higher than 92% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
HY
Hyper · Hyper
0.12.0 before 0.13.10; 0.14.0 before 0.14.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-21299
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-21299
Product
https://crates.io/crates/hyper
Patch
https://github.com/hyperium/hyper/commit/8f93123efef5c1361086688fe4f34c83c89cec02
Third Party Advisory
https://github.com/hyperium/hyper/security/advisories/GHSA-6hfq-h8hq-87mf
Third Party Advisory
https://portswigger.net/research/http-desync-attacks-request-smuggling-reborn
Third Party Advisory
https://rustsec.org/advisories/RUSTSEC-2021-0020.html
More from Hyper
9.8
CVE-2024-23741
An issue in Hyper on macOS version 3.4.1 and before, allows remote attackers to execute arbitrary code via the RunAsNode and enableNodeClilnspectArguments settings
9.8
CVE-2020-35863
An issue was discovered in the hyper crate before 0.12.34 for Rust
9.1
CVE-2021-32714
hyper is an HTTP library for Rust
7.5
CVE-2023-26964
An issue was discovered in hyper v0.13.7
7.5
CVE-2022-31394
Hyperium Hyper before 0.14.19 does not allow for customization of the max_header_list_size method in the H2 third-party software, allowing attackers to perform HTTP2 attacks
