Medium severity · published Mar 19, 2020
CVE-2020-5267
In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers
4.8
CVSS
1.5%
EPSS
No
On KEV
Description
In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
High
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.5% · higher than 75% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
AC
Actionview · Rubyonrails
before 5.2.4.2; 6.0.0 before 6.0.2.2 · source: NVD
DL
Debian Linux · Debian
8.0 · source: NVD
FE
Fedora · Fedoraproject
33 · source: NVD
LE
Leap · Opensuse
15.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-5267
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-5267
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00019.html
Exploit
http://www.openwall.com/lists/oss-security/2020/03/19/1
Patch
https://github.com/rails/rails/commit/033a738817abd6e446e1b320cb7d1a5c15224e9a
Exploit
https://github.com/rails/rails/security/advisories/GHSA-65cv-r6x7-79hv
Mailing List
https://lists.debian.org/debian-lts-announce/2020/03/msg00022.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XJ7NUWXAEVRQCROIIBV4C6WXO6IR3KSB/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
