Medium severity · published Aug 13, 2020
CVE-2020-16301
A buffer overflow vulnerability in okiibm_print_page1() in devices/gdevokii.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a…
5.5
CVSS
1.9%
EPSS
No
On KEV
Description
A buffer overflow vulnerability in okiibm_print_page1() in devices/gdevokii.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack vector
Local
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.9% · higher than 80% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0; 10.0 · source: NVD
GH
Ghostscript · Artifex
before 9.52 · source: NVD
UL
Ubuntu Linux · Canonical
16.04; 18.04; 20.04 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-16301
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-16301
Exploit
https://bugs.ghostscript.com/show_bug.cgi?id=701808
git.ghostscript.com
https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=f54414c8b15b2c27d1dcadd92cfe84f6d15f18dc
Mailing List
https://lists.debian.org/debian-lts-announce/2020/08/msg00032.html
Third Party Advisory
https://security.gentoo.org/glsa/202008-20
Third Party Advisory
https://usn.ubuntu.com/4469-1/
Third Party Advisory
https://www.debian.org/security/2020/dsa-4748
More from Ghostscript
7.8
CVE-2017-8291
Artifex Ghostscript Type Confusion Vulnerability
9.9
CVE-2021-3781
A trivial sandbox (enabled with the `-dSAFER` option) escape flaw was found in the ghostscript interpreter by injecting a specially crafted pipe command
9.8
CVE-2025-27837
An issue was discovered in Artifex Ghostscript before 10.05.0
9.8
CVE-2025-27836
An issue was discovered in Artifex Ghostscript before 10.05.0
9.8
CVE-2025-27832
An issue was discovered in Artifex Ghostscript before 10.05.0
