Medium severity · published Sep 1, 2020
CVE-2020-15704
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading
5.5
CVSS
0.4%
EPSS
No
On KEV
Description
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 30% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PP
Ppp · Canonical
before 2.4.7-1\+ubuntu1.16.04.3; before 2.4.7-2\+2ubuntu1.3; before 2.4.7-2\+4.1ubuntu5.1; before 2.4.5-5ubuntu1.4; before 2.4.5-5.1ubuntu2.3\+esm2 · source: NVD
