High severity · published Sep 11, 2020
CVE-2020-15166
In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability
7.5
CVSS
3.3%
EPSS
No
On KEV
Description
In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability. Users with TCP transport public endpoints, even with CURVE/ZAP enabled, are impacted. If a raw TCP socket is opened and connected to an endpoint that is fully configured with CURVE/ZAP, legitimate clients will not be able to exchange any message. Handshakes complete successfully, and messages are delivered to the library, but the server application never receives them. This is patched in version 4.3.3.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.3% · higher than 89% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0 · source: NVD
FE
Fedora · Fedoraproject
32; 33 · source: NVD
LI
Libzmq · Zeromq
before 4.3.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-15166
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-15166
Patch
https://github.com/zeromq/libzmq/pull/3913
Patch
https://github.com/zeromq/libzmq/pull/3973
Patch
https://github.com/zeromq/libzmq/security/advisories/GHSA-25wp-cf8g-938m
Mailing List
https://lists.debian.org/debian-lts-announce/2020/11/msg00017.html
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BZ5IMNQXDB52JFBXHFLK4AHVORFELNNG/
lists.fedoraproject.org
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YFW2ZELCCPS4VLU4OSJOH5YL6KFKTFYW/
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
