Critical severity · published Sep 15, 2020
CVE-2020-15148
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input
10.0
CVSS
77.5%
EPSS
No
On KEV
Description
Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)77.5% · higher than 100% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
YI
Yii · Yiiframework
before 2.0.38 · source: NVD
Affected product
YI
Yii
Yiiframework
More from Yii
9.8
CVE-2024-58136
Yiiframework Yii Improper Protection of Alternate Path Vulnerability
9.8
CVE-2025-2690
yiisoft Yii2 MockClass.php generate deserialization
9.8
CVE-2025-2689
yiisoft Yii2 SortableIterator.php getIterator deserialization
9.8
CVE-2023-47130
Unsafe deserialization of user data in yiisoft/yii
9.8
CVE-2015-5467
web\ViewAction in Yii (aka Yii2) 2.x before 2.0.5 allows attackers to execute any local .php file via a relative path in the view parameeter