High severity · published Jul 10, 2020
CVE-2020-11081
osquery before version 4.4.0 enables a privilege escalation vulnerability
8.2
CVSS
0.6%
EPSS
No
On KEV
Description
osquery before version 4.4.0 enables a privilege escalation vulnerability. If a Window system is configured with a PATH that contains a user-writable directory then a local user may write a zlib1.dll DLL, which osquery will attempt to load. Since osquery runs with elevated privileges this enables local escalation. This is fixed in version 4.4.0.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 48% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OS
Osquery · Linuxfoundation
before 4.4.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-11081
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-11081
Patch
https://github.com/osquery/osquery/commit/4d4957f12a6aa0becc9d01d9f97061e1e3d809c5
Exploit
https://github.com/osquery/osquery/issues/6426
Patch
https://github.com/osquery/osquery/pull/6433
Release Notes
https://github.com/osquery/osquery/releases/tag/4.4.0
Third Party Advisory
https://github.com/osquery/osquery/security/advisories/GHSA-2xwp-8fv7-c5pm
More from Osquery
9.1
CVE-2020-1887
Incorrect validation of the TLS SNI hostname in osquery versions after 2.9.0 and before 4.2.0 could allow an attacker to MITM osquery traffic in the absence of a configured root…
8.1
CVE-2019-3567
In some configurations an attacker can inject a new executable path into the extensions.load file for osquery and hard link a parent folder of a malicious binary to a folder with…
7.8
CVE-2018-6336
An issue was discovered in osquery
5.2
CVE-2020-26273
osquery is a SQL powered operating system instrumentation, monitoring, and analytics framework
